FreeBSD Manual Pages
ACPI(4) FreeBSD Kernel Interfaces Manual ACPI(4) NAME acpi -- Advanced Configuration and Power Management support SYNOPSIS device acpi options ACPI_DEBUG DESCRIPTION The acpi driver provides support for the Intel/Microsoft/Compaq/Toshiba ACPI standard. This support includes platform hardware discovery (super- seding the PnP and PCI BIOS), as well as power management (superseding APM) and other features. ACPI core support is provided by the ACPI CA reference implementation from Intel. Note that the acpi driver is automatically loaded by the bootloader, and should not normally be compiled into the kernel. ENVIRONMENT This support is still experimental, and thus there are many debugging and tuning options which are managed via the kernel environment space, and set in the loader(8) before booting the kernel. Debugging is separated between layers and levels, where a layer is a por- tion of the ACPI subsystem, and a level is a particular kind of debugging output. Both layers and levels are specified as a whitespace-separated list of tokens, with layers listed in debug.acpi.layer and levels in debug.acpi.level. The supported layers are: ACPI_UTILITIES ACPI_HARDWARE ACPI_EVENTS ACPI_TABLES ACPI_NAMESPACE ACPI_PARSER ACPI_DISPATCHER ACPI_EXECUTER ACPI_RESOURCES ACPI_CA_DEBUGGER ACPI_OS_SERVICES ACPI_CA_DISASSEMBLER ACPI_ALL_COMPONENTS ACPI_BUS ACPI_SYSTEM ACPI_POWER ACPI_EC ACPI_AC_ADAPTER ACPI_BATTERY ACPI_BUTTON ACPI_PROCESSOR ACPI_THERMAL ACPI_FAN ACPI_ALL_DRIVERS The supported levels are: ACPI_LV_ERROR ACPI_LV_WARN ACPI_LV_INIT ACPI_LV_DEBUG_OBJECT ACPI_LV_INFO ACPI_LV_ALL_EXCEPTIONS ACPI_LV_INIT_NAMES ACPI_LV_PARSE ACPI_LV_LOAD ACPI_LV_DISPATCH ACPI_LV_EXEC ACPI_LV_NAMES ACPI_LV_OPREGION ACPI_LV_BFIELD ACPI_LV_TABLES ACPI_LV_VALUES ACPI_LV_OBJECTS ACPI_LV_RESOURCES ACPI_LV_USER_REQUESTS ACPI_LV_PACKAGE ACPI_LV_VERBOSITY1 ACPI_LV_ALLOCATIONS ACPI_LV_FUNCTIONS ACPI_LV_OPTIMIZATIONS ACPI_LV_VERBOSITY2 ACPI_LV_ALL ACPI_LV_MUTEX ACPI_LV_THREADS ACPI_LV_IO ACPI_LV_INTERRUPTS ACPI_LV_VERBOSITY3 ACPI_LV_AML_DISASSEMBLE ACPI_LV_VERBOSE_INFO ACPI_LV_FULL_TABLES ACPI_LV_EVENTS ACPI_LV_VERBOSE Selection of the appropriate layer and level values is important to avoid massive amounts of debugging output. Check the code to see which you need. Debugging output by the ACPI CA subsystem is prefixed with the module name in lowercase, followed by a source line number. Output from the FreeBSD-local code follows the same format, but the module name is upper- cased. To disable the acpi driver completely, set the kernel environment vari- able hint.acpi.0.disabled to 1. Some i386 machines totally fail to oper- ate with some or all of ACPI disabled. Other i386 machines fail with ACPI enabled. Non-i386 platforms do not support operating systems which do not use ACPI. Disabling all or part of ACPI on non-i386 platforms may result in a non-functional system. The acpi driver comprises a set of drivers, which may be selectively dis- abled in case of problems. To disable a sub-driver, list it in the ker- nel environment variable debug.acpi.disable. ACPI sub-devices and features that can be disabled: bus (feature) Probes and attaches subdevices. Disabling will avoid scanning the ACPI namespace entirely. children (feature) Attaches standard ACPI sub-drivers and devices enu- merated in the ACPI namespace. Disabling this has a similar effect to disabling ``bus'', except that the ACPI namespace will still be scanned. button (device) Supports ACPI button devices (typically power and sleep buttons). ec (device) Supports the ACPI Embedded Controller interface, used to communicate with embedded platform controllers. isa (device) Supports an ISA bus bridge defined in the ACPI names- pace, typically as a child of a PCI bus. lid (device) Supports an ACPI laptop lid switch, which typically puts a system to sleep. pci (device) Supports Host to PCI bridges. cpu (device) Supports CPU power-saving and speed-setting functions. thermal (device) Supports system cooling and heat management. timer (device) Implements a timecounter using the ACPI fixed-fre- quency timer. It is also possible to avoid portions of the ACPI namespace which may be causing problems, by listing the full path of the root of the region to be avoided in the kernel environment variable debug.acpi.avoid. The object and all of its children will be ignored during the bus/children scan of the namespace. The ACPI CA code will still know about the avoided region. OVERRIDING YOUR BIOS BYTECODE ACPI interprets bytecode named AML, ACPI Machine Language, provided by the BIOS vendor as a memory image at boot time. Sometimes, the AML code contains a problem that does not appear in the Microsoft implementation. So we provide a way to override it with your own AML code. In order to load your AML code, you must edit /boot/loader.conf and include the following lines. acpi_dsdt_load="YES" acpi_dsdt_name="/boot/acpi_dsdt.aml" #You may change the name. In order to prepare your AML code, you will need the acpidump(8) and iasl(1) utilities and some ACPI knowledge. TUNABLES acpi_dsdt_load Enables loading of a custom ACPI DSDT. acpi_dsdt_name Name of the DSDT table to load, if loading is enabled. debug.acpi.disable Selectively disables portions of ACPI for debugging purposes. hint.acpi.0.disabled Disables all of ACPI. hw.acpi.ec.poll_timeout Delay in milliseconds to wait for the EC to respond. Try increasing this number if you get the error AE_NO_HARDWARE_RESPONSE. hw.acpi.reset_video Enables calling the VESA reset BIOS vector on the resume path. Some graphic chips have problems such as LCD white-out after resume. Try setting this to 0 if this causes problems for you. hw.acpi.os_name Some systems' ASL may have problems because they look for names of Microsoft operating systems. This tunable overrides the default value of "FreeBSD". hw.acpi.pci.link.%d.%d.%d.irq Override the interrupt to use. hw.acpi.verbose Turn on verbose debugging information about what ACPI is doing. SYSCTLS hw.acpi.cpu.performance_speed Sets the speed of the CPU, if it supports multiple speeds, while in the performance power profile. hw.acpi.cpu.economy_speed Sets the speed of the CPU, if it supports multiple speeds, while in the economy power profile. hw.acpi.cpu.cx_history Debugging information listing all sleep states and the number of long and short sleeps for each one. The counters are reset when hw.acpi.cpu.cx_lowest is modified. hw.acpi.cpu.cx_lowest Zero-based index of the lowest CPU idle state to use. A schedul- ing algorithm will select between 0...index for the state to use during the next sleep. To enable ACPI CPU idling control, machdep.cpu_idle_hlt must be set to 1. hw.acpi.cpu.cx_supported List of supported CPU idle states and their transition latency in microseconds. Each state has a type, C1-3. C1 is equivalent to the ia32 HLT instruction, C2 provides a deeper sleep with the same semantics, and C3 provides the deepest sleep but addition- ally requires bus mastering to be disabled. Deeper sleeps pro- vide more power savings but increased transition latency when an interrupt occurs. COMPATIBILITY ACPI is only found and supported on i386/ia32, ia64, and amd64. SEE ALSO loader.conf(5), acpiconf(8), acpidump(8), config(8), iasl(8) Compaq Computer Corporation, Intel Corporation, Microsoft Corporation, Phoenix Technologies Ltd., and Toshiba Corporation, Advanced Configuration and Power Interface Specification, August 25, 2003, http://acpi.info/spec.htm. AUTHORS The ACPI CA subsystem is developed and maintained by Intel Architecture Labs. The following people made notable contributions to the ACPI subsystem in FreeBSD: Michael Smith, Takanori Watanabe <takawata@jp.FreeBSD.org>, Mitsuru IWASAKI <iwasaki@jp.FreeBSD.org>, Munehiro Matsuda, Nate Lawson, the ACPI-jp mailing list at <acpi-jp@jp.FreeBSD.org>, and many other con- tributors. This manual page was written by Michael Smith <msmith@FreeBSD.org>. BUGS If the acpi driver is loaded as a module when it is already linked as part of the kernel, odd things may happen. FreeBSD 11.1 July 2, 2001 FreeBSD 11.1
NAME | SYNOPSIS | DESCRIPTION | ENVIRONMENT | OVERRIDING YOUR BIOS BYTECODE | TUNABLES | SYSCTLS | COMPATIBILITY | SEE ALSO | AUTHORS | BUGS
Want to link to this manual page? Use this URL:
<https://www.freebsd.org/cgi/man.cgi?query=acpi&sektion=4&manpath=FreeBSD+5.2-RELEASE>