FreeBSD Manual Pages
WI(4) FreeBSD Kernel Interfaces Manual WI(4) NAME wi -- WaveLAN/IEEE, PRISM-II and Spectrum24 802.11DS wireless network driver SYNOPSIS device wi DESCRIPTION The wi driver provides support for wireless network adapters based around the Lucent Hermes, Intersil PRISM-II, Intersil PRISM-2.5, and Symbol Spectrum24 chipsets. All four chipsets provide a similar interface to the driver. All host/device interaction is via programmed I/O. Supported features include 802.11 and 802.3 frames, power management, BSS, IBSS, WDS and old-style Lucent ad-hoc operation modes. Cards based on the Intersil PRISM-II and PRISM-2.5 chips also support a host-based access point mode which allows a card to act as a normal access point (with some assistance from the wi driver). The Lucent Hermes and Symbol Spectrum24 chipsets do not contain this functionality. PRISM-II and PRISM-2.5 chips do not sup- port the WDS functionality. The wi driver encapsulates all IP and ARP traffic as 802.11 frames, how- ever it can receive either 802.11 or 802.3 frames. Transmit speed is selectable between 1Mbps fixed, 2Mbps fixed, 2Mbps with auto fallback, 5.5Mbps, 8Mbps, or 11Mbps depending on your hardware. The Lucent Wave- LAN/IEEE Silver and Gold cards as well as the Intersil and Symbol cards have support for WEP encryption. The WaveLAN Gold as well as newer Intersil and Symbol cards support 104bit keys, the others only accept 40bit keys. The Lucent WaveLAN/IEEE Bronze cards do not support WEP at all. To enable encryption, use the wicontrol(8) utility to set your keys, or use ifconfig(8) as shown below. By default, the wi driver configures the card for BSS operation (aka in- frastructure mode). This mode requires the use of an access point (base station). The wi driver also supports an point-to-point mode where the ssid is ignored and stations can communicate amongst themselves without the aid of an access point. Note that there are two possible point-to-point modes. One mode, referred to as ``ad-hoc demo mode'', or ``legacy Lucent ad-hoc mode'', predates the IEEE 802.11 specification and so may not interoperate with cards from different vendors. The standardized point- to-point mode, is called IBSS (or confusingly just ad-hoc mode), but is not supported by cards with very old firmware revisions. If your cards supports IBSS mode, it is recommended that you use it in preference to the ``ad-hoc demo mode'' in new installations. Cards based on the Intersil PRISM-II and PRISM-2.5 chips also have a host-based access point mode which allows the card to act as an access point (base station). Access points are different than operating in IBSS mode. They operate in BSS mode. They allow for easier roaming and bridge all ethernet traffic such that machines connected via an access point appear to be on the local ethernet segment. For more information on configuring this device, see ifconfig(8). Cards supported by the wi driver come in a variety of packages, though the most common are of the PCMCIA type. In many cases, the PCI version of a wireless card is simply a PCMCIA card bundled with a PCI adapter. The PCI adapters come in two flavors: true PCMCIA bridges and dumb PCMCIA bridges. A true PCMCIA bridge (such as those sold by Lucent) will attach as a real PCMCIA controller. The wireless card will then attach to the PCMCIA bus. Wireless cards in PCMCIA slots may be inserted and ejected on the fly. A dumb bridge, on the other hand, does not show up as a true PCMCIA bus. The wireless card will simply appear to the host as a normal PCI device and will not require any PCMCIA support. Cards in this type of adapter should only be removed when the machine is powered down. The following cards are among those supported by the wi driver: Card Chip Bus ---------------------------------------------------------------- 3Com AirConnect 3CRWE737A Spectrum24 PCMCIA 3Com AirConnect 3CRWE777A Prism-II PCI ACTIONTEC HWC01170 Prism-2.5 PCMCIA Addtron AWP-100 Prism-II PCMCIA Agere Orinoco Hermes PCMCIA Buffalo AirStation Prism-II PCMCIA Buffalo AirStation Prism-II CF Cabletron RoamAbout Hermes PCMCIA Compaq Agency NC5004 Prism-II PCMCIA Contec FLEXLAN/FX-DS110-PCC Prism-II PCMCIA Corega PCC-11 Prism-II PCMCIA Corega PCCA-11 Prism-II PCMCIA Corega PCCB-11 Prism-II PCMCIA Corega CGWLPCIA11 Prism-II PCI Dlink DWL520 Prism-2.5 PCI Dlink DWL650 Prism-2.5 PCMCIA ELSA XI300 Prism-II PCMCIA ELSA XI800 Prism-II CF EMTAC A2424i Prism-II PCMCIA Ericsson Wireless LAN CARD C11 Spectrum24 PCMCIA Gemtek WL-311 Prism-2.5 PCMCIA Hawking Technology WE110P Prism-2.5 PCMCIA I-O DATA WN-B11/PCM Prism-II PCMCIA Intel PRO/Wireless 2011 Spectrum24 PCMCIA Intersil Prism II Prism-II PCMCIA Intersil Mini-PCI Prism-2.5 PCI Linksys Instant Wireless WPC11 Prism-II PCMCIA Linksys Instant Wireless WPC11 2.5 Prism-2.5 PCMCIA Lucent WaveLAN Hermes PCMCIA NANOSPEED ROOT-RZ2000 Prism-II PCMCIA NDC/Sohoware NCP130 Prism-II PCI NEC CMZ-RT-WP Prism-II PCMCIA Netgear MA401 Prism-II PCMCIA NTT-ME 11Mbps Wireless LAN Prism-II PCMCIA Proxim RangeLAN-DS Prism-II PCMCIA Samsung MagicLAN SWL-2000N Prism-II PCMCIA Socket Low Power WLAN-CF Prism-II CF SMC 2602 EZ Connect (3.3V) Prism-II PCI or PCMCIA SMC 2632 EZ Connect Prism-II PCMCIA Symbol Spectrum24 Spectrum24 PCMCIA TDK LAK-CD011WL Prism-II PCMCIA Several vendors sell PCI adapters built around the PLX Technology 9050 or 9052 chip. The following such adapters are supported or expected to work: 3Com AirConnect 3CRWE777A (3.3V) Belkin F5D6000 (a rebadged WL11000P) Eumitcom WL11000P Global Sun Technology GL24110P (untested) Global Sun Technology GL24110P02 LinkSys WDT11 (a rebadged GL24110P02) Netgear MA301 US Robotics 2415 (rebadged WL11000P) EXAMPLES The following examples utilize ifconfig(8) for simplicity, however, wicontrol(8) can also be used to set wireless parameters. Join an existing BSS network (ie: connect to an access point): # ifconfig wi0 inet 192.168.0.20 netmask 0xffffff00 Join a specific BSS network with network name ``my_net''. # ifconfig wi0 inet 192.168.0.20 netmask 0xffffff00 ssid my_net Join a specific BSS network with WEP encryption: # ifconfig wi0 inet 192.168.0.20 netmask 0xffffff00 ssid my_net \ wepkey 0x8736639624 Join a Lucent legacy demo ad-hoc network with network name ``my_net''. # ifconfig wi0 inet 192.168.0.20 netmask 0xffffff00 ssid my_net \ mediaopt adhoc Create an IBSS network with network name ``my_net''. # ifconfig wi0 inet 192.168.0.20 netmask 0xffffff00 ssid my_net \ mediaopt ibss-master Note: The infrastructure for mediaopt ibss-master has not been committed yet. Join an IBSS network with network name ``my_net''. # ifconfig wi0 inet 192.168.0.22 netmask 0xffffff00 ssid my_net \ mediaopt ibss Note: The infrastructure for mediaopt ibss has not been committed yet. Create a host-based access point (Prism only): # ifconfig wi0 inet 192.168.0.10 netmask 0xffffff00 ssid my_ap \ mediaopt hostap Create a host-based access point with WEP enabled (Prism only): # ifconfig wi0 inet 192.168.0.10 netmask 0xffffff00 ssid my_ap \ wepkey 0x1234567890 mediaopt hostap Create a host-based wireless bridge to fxp0 (Prism only): Add BRIDGE to the kernel config. # ifconfig wi0 inet up ssid my_ap mediaopt hostap # sysctl net.link.ether.bridge=1 # sysctl net.link.ether.bridge_cfg="wi0 fxp0" # sysctl net.inet.ip.forwarding=1 This will give you approximately the same functionality as an access point. DIAGNOSTICS wi%d: init failed The WaveLAN card failed to come ready after an ini- tialization command was issued. wi%d: failed to allocate %d bytes on NIC The driver was unable to allo- cate memory for transmit frames in the NIC's on-board RAM. wi%d: device timeout The WaveLAN failed to generate an interrupt to acknowledge a transmit command. SEE ALSO an(4), arp(4), netintro(4), ifmedia(4), hostname.if(5), ifconfig(8), wicontrol(8) HCF Light programming specification, http://www.wavelan.com. HISTORY The wi device driver first appeared in FreeBSD 3.0. AUTHORS The wi driver was written by Bill Paul <wpaul@ctr.columbia.edu>. This man page comes from OpenBSD. CAVEATS The original Lucent WaveLAN cards usually default to channel 3; newer cards use channel 10 by default. Non-Lucent cards vary, for instance the Addtron cards use channel 11 by default. Different regulatory domains have different default channels. See wicontrol(8) for information on how to change the channel. IBSS creation does not currently work with Symbol cards. Prism2 host-based access point mode has bugs for firmware versions prior to 0.8.3. Lucent cards prior to firmware version 6.0.4 do not support ibss mode. FreeBSD 11.1 May 2, 2002 FreeBSD 11.1
NAME | SYNOPSIS | DESCRIPTION | EXAMPLES | DIAGNOSTICS | SEE ALSO | HISTORY | AUTHORS | CAVEATS
Want to link to this manual page? Use this URL:
<https://www.freebsd.org/cgi/man.cgi?query=wi&sektion=4&manpath=FreeBSD+4.6-RELEASE>